Datas sequencias no Excel | Excelmax Soluções e Controles

segunda-feira, fevereiro 18, 2013

Datas sequencias no Excel

Datas sequenciais automáticas no Excel.

dias, datas, sequencial, excel
O objetivo desta matéria é demonstrar como podemos criar uma planilha com os dias sequenciais de determinado mês.

Isto para que a mesma possa ser utilizada, por exemplo, na criação de um cartão ponto ou outro controle qualquer que necessite de uma lista com os dias do mês.


A parte inicial da planilha apresentará qual é o primeiro e o último dia do mês desejado.

dias, datas, sequencial, excel, fimmês, mês, último dia, período
A célula que contém o primeiro dia do mês, receberá esta informação por digitação (Ex.: "01/01/2013", 01/06/2013, ... ). Na célula do último dia do mês, inserimos a função 'FIMMÊS'.

O número 0 (zero) que aparece na função 'FIMMÊS'  faz com que a data (Célula "C2") avance para o último dia do mesmo mês. Se inserirmos o número 1, a função 'FIMMÊS' avançará para o último dia do mês seguinte (e assim por diante).

Se desejarmos retroceder, ou voltar para meses anteriores, digitamos um número negativo. (Ex.: se digitarmos, no exemplo da figura ao lado, o número -3 na função 'FIMMÊS', a data a ser retornada será: '31/03/2013' .

Criando a lista de dias sequenciais com base nas datas do Período

A criação da lista de dias sequenciais pode ser criada de várias maneiras. Vamos utilizar uma fórmula que servirá para todas as 31 células, que é o limite máximo de dias de um mês.
  • Com base na figura acima, digitamos na célula "B5" a seguinte fórmula:
SE(ÉTEXTO(B4);$C$2SE(MÊS($C$2)=MÊS(B4+1);B4+1))
            Explicação
SE(ÉTEXTO(B4);$C$2 : Se a célula "B4" for texto, retorna a data inicial (célula "C2")
SE(MÊS($C$2)=MÊS(B4+1);B4+1 : Se o mês da célula "C2" for igual ao mês da célula anterior da atual, + 1 (dia), então retorna a data da célula anterior + 1 (dia)
Se as duas partes da fórmula, apresentadas acima forem falsas (ou não retornarem valor, então valor retornado será = 0 (zero)

  • Com base na figura acima, digitamos na célula "C5" a seguinte fórmula:
=SE(B5=0;"";PRI.MAIÚSCULA(TEXTO(B5;"DDDD")))
            Explicação
TEXTO(B5;"DDDD") : Esta função retorna apenas o dia da semana da célula referenciada.
As fórmulas inseridas nas células "B5" e "C5" podem ser copiadas para as células abaixo como podemos observar na figura a seguir.

lista, dias, més, sequencial, excel





























Na próxima matéria estarei explicando como podemos aplicar bordas às células com informações com o recurso "Formatação Condicional". Nesta postagem também estará disponível um link para download da planilha exemplo.

Abraço a todos e até mais ...

Consultor e Professor Ivair Claudio Ferrari

Sobre o autor: Ivair Ferrari é Certificado: Microsoft Office Excel Specialist; Consultoria e Desenvolvimento de Soluções e Softwares em Excel/VBA, Bancos de dados Access, Firebird, Oracle, Interação com SAP/R3 e Treinamentos In-Company. YouTube | Facebook | LinkedIn | Twitter | Google Plus

Um comentário :

Seja um participante desta comunidade !
Deixe aqui seu comentário e/ou sugestão.
Obrigado !

Ivair Claudio Ferrari

atualizar, excel, excelmax, ivair ferrari
topo, excelmax, excel, ivair ferrari