Tabela Móvel em uma Base de Dados (Desloc & Procv (Vlookup)) | Excelmax Soluções e Controles

sábado, dezembro 03, 2011

Tabela Móvel em uma Base de Dados (Desloc & Procv (Vlookup))

Desloc, Procv, Base de Dados
Quando trabalhamos com uma base de dados de tamanho grande ou médio, podemos visualizar, analisar ou filtrar os dados com algumas ferramentas do Excel.

Porém, podemos visualizar os dados ou parte deles de outra forma: elaborando um mini-tabela que percorra a base maior.


Esta postagem tem por objetivo demonstrar como podemos fazer isto e ainda, como os dados ficarão resumidos a uma parte da tabela maior, podemos demonstrar estes valor em gráficos.



A figura abaixo demonstra como é a nossa base de dados.
Tabela de Dados, Excel, dados

Criamos e formatamos agora a mini-tabela. Esta mini-tabela tem o mesmo cabeçalho da tabela base.
Excel, tabela, dados, desloc, procv
Agora, criamos as fórmulas para que a mini-tabela possa trazer as informações desejadas. Além das fórmulas, inserimos o objeto 'Barra de Rolagem' para que, com apenas alguns cliques do mouse, a mini-tabela possa percorra a tabela de dados. Observe a figura a seguir.
tabela, dados, Excel
A barra de rolagem será vinculada a uma célula (em nosso exemplo o vínculo será na célula 'I3'). Esta célula apresentará um número que será incrementado (aumentará) em 1 a cada clique com o mouse sobre a barra de rolagem. Isso fará com que a mini-tabela, com a ajuda de fórmulas, possa percorrer a tabela de dados. A barra de rolagem será colocada ao lado da mini-tabela.

A primeira fórmula a ser inserida na célula 'I5' da mini-tabela é a seguinte:
  • =DESLOC($A$3;$I$3;0;1;1)
Note que a célula 'I3' (destacada acima) se refere ao valor vinculado à barra de rolagem conforme mencionado anteriormente.
Desloc, Tabela Móvel , Excel
Nas linhas abaixo da primeira fórmula, inserimos as demais fórmulas com apenas uma alteração: o número da linha a ser selecionada = I3 + 1 (na primeira linha abaixo), I3 + 2 ( na segunda linha abaixo) e assim sucessivamente até o final da mini-tabela.
  • =DESLOC($A$3;$I$3+1;0;1;1)
Nas demais colunas: J, K, L, M e N, inserimos a função PROCV com base no número retornado na coluna 'I'. 
  • Célula 'J5': =PROCV(I5;$A$3:$E$31;2;FALSO)
  • Célula 'K5': =PROCV(I5;$A$3:$E$31;3;FALSO)
  • Célula 'L5': =PROCV(I5;$A$3:$E$31;4;FALSO)
  • Célula 'M5': =PROCV(I5;$A$3:$E$31;5;FALSO)
  • Célula 'N5': =PROCV(I5;$A$3:$E$31;6;FALSO)
Após inserir as fórmulas acima (linha 5), podemos copiá-las para baixo até a última linha da mini-tabela.

Assim, podemos clicar na Barra de Rolagem e percorrer a base de dados com a mini-tabela. Podemos visualizar isto na figura abaixo.
dados, mini-tabela, Excel
Download: Tabela Móvel

Este endereço da acesso a um vídeo no YouTube que da maiores informações referente as funções Procv, Desloc e Corresp:


Até a próxima.


Sobre o autor: Ivair Ferrari é Certificado: Microsoft Office Excel Specialist; Consultoria e Desenvolvimento de Soluções e Softwares em Excel/VBA, Bancos de dados Access, Firebird, Oracle, Interação com SAP/R3 e Treinamentos In-Company. YouTube | Facebook | LinkedIn | Twitter | Google Plus

7 comentários :

  1. Esse exemplo é interessante, pois essa funcionalidade é muito útil no dia-a-dia.

    ResponderExcluir
  2. Ótimo , gostei muito desse macete. Irá me ajudar bastante. Só queria saber como fez para aquela cor vermelha ficar rodando de acordo com o controle.

    Poderia explicar.

    ResponderExcluir
    Respostas
    1. Primeiro, obrigado !!! pela participação com seu comentário.
      A cor Vermelha que acompanha os itens da tabela ao lado é aplicada através do recurso "Formatação Condicional".

      Faça download da planilha no link acima (Download: Tabela Móvel) e observe esta formatação. Em caso de permanecer a dúvida, mande email: ivairferrari@gmail.com que darei maiores explicações.

      Excluir
  3. Ok, agora saquei como se faz.. Valeu mesmo, você estar de parabéns tanto pelos assuntos como pelo site. Pq/ você não faz um fórum cara? Seria bem interessante para todos os membros que aquí frequenta.



    Abraços,

    ResponderExcluir
  4. muito bom, meus parabéns!

    Crie cursos/aulas online para os internautas aprenderem muito mais.
    eu por exemplo seria um dos alunos.

    abraço.

    ResponderExcluir
    Respostas
    1. Primeiro, muito grato pelo comentário.
      Segundo, estou estudando esta questão. Em breve publico noticias.

      Grande abraço!
      Consultor e Professor Ivair Claudio Ferrari.

      Excluir

Seja um participante desta comunidade !
Deixe aqui seu comentário e/ou sugestão.
Obrigado !

Ivair Claudio Ferrari

atualizar, excel, excelmax, ivair ferrari
topo, excelmax, excel, ivair ferrari