Série Gráficos Personalizados: Valores Acima da Média | Excelmax Soluções e Controles

quinta-feira, abril 16, 2015

Série Gráficos Personalizados: Valores Acima da Média

Gráfico Personalizado: GASTOS COM VALORES ACIMA DA MÉDIA

Gráficos Personalizados, gráficos, média, média, avg, average, comparativo, visual, waterfall, comparativo
Os Gráficos, com certeza, nos dão uma visão clara e rápida a respeito de informações de bases grandes ou mesmo de pequenas tabelas.

A criação de gráficos bem elaborados é uma Arte. Fazer gráficos comuns, utilizando modelos prontos e sem criatividade, podem frustrar, não dar o resultado ou causar o impacto desejado.


O objetivo desta série de 4 matérias, é demonstrar quais são alguns dos segredos de elaborar bons gráficos: os gráficos profissionais.

Um dos principais segredos

Na verdade, a grande sacada está em fazer tabelas bem elaboradas, que é de onde virão os dados que formarão o gráfico.

De nada adianta, colorir o gráfico, utilizar opções '3D', destacar os tipos de fonte (letras) utilizadas entre outras coisas comuns utilizadas.

Para entender melhor, vamos a um exemplo. A figura a seguir, representa o gráfico que iremos elaborar.

Gráficos Personalizados, gráficos, média, média, avg, average, comparativo, visual













Este é um simples gráficos de barras, com algumas formatações. Mas veremos que há alguns pormenores que devem ser observados para chegarmos a este resultado.

A Tabela de Dados

A tabela a seguir é a base para a criação do gráfico apresentado acima. Nesta tabela, temos uma coluna com os 12 meses do ano na coluna "A" e valores aleatórios na coluna "B". Na célula "B17" temos a média dos valores.
 
Tabela, média, média, avg, average
Para que o gráfico possa ser feito, precisamos trabalhar os valores nas colunas da tabela (Colunas 'C', 'D' e 'E').
Na coluna "C" colocamos uma fórmula que exibe apenas os valores que estão acima da média

Na coluna "D" colocamos uma fórmula que exibe apenas os valores que estão abaixo da média

E na coluna "E" colocamos a fórmula que exibe a média.
 

As Fórmulas


Coluna "C" - Abaixo da média: =SE(B4<$B$17;B4;0)
Esta fórmula é colocada na célula "C4" e repetida nas linhas abaixo até a linha 15.

Coluna "D" - Abaixo da média: =SE(B4>$B$17;B4;0)
Esta fórmula é colocada na célula "D4" e repetida nas linhas abaixo até a linha 15.

Coluna "E" - Média: =$B$17
Esta fórmula é colocada na célula "E4" e repetida nas linhas abaixo até a linha 15. O Valor fica repetido para que apareça no gráfico uma linha reta demonstrando onde fica a média dos valores.
 
Tabela, média, média, avg, average, dados, acima, abaixo


Note que é exatamente o que acontece: valores abaixo da média na coluna "C", valores acima da média na coluna "D" e os valores da média, repetidos na coluna "E". 

Selecionamos esta tabela e inserimos um gráfico de "Colunas Agrupadas





Explicando o gráfico

A figura abaixo, exibe na cor azul, os valores originais. Esta coluna deve ser eliminada. Para fazer isto, basta clicar com o mouse sobre uma das barras na cor azul e deletar a mesma.
 
gráfico, tabela, média, cores, meses,




As barras na cor Vermelha, exibem os valores abaixo da média.As barras na cor Verde, exibem os valores acima da média.Na cor Laranja, vemos as barras que representam os valores médios.

Na próxima matéria, estarei explicando como fazer para ajustar (formatar) o gráfico para que ele fique da forma como apresentado no início desta maneira.

Fique atendo e, se puder, compartilhe com seus amigos.

Grande abraço a todos.

Consultor e Professor: Ivair Claudio Ferrari.

Sobre o autor: Ivair Ferrari é Certificado: Microsoft Office Excel Specialist; Consultoria e Desenvolvimento de Soluções e Softwares em Excel/VBA, Bancos de dados Access, Firebird, Oracle, Interação com SAP/R3 e Treinamentos In-Company. YouTube | Facebook | LinkedIn | Twitter | Google Plus

Um comentário :

Seja um participante desta comunidade !
Deixe aqui seu comentário e/ou sugestão.
Obrigado !

Ivair Claudio Ferrari

atualizar, excel, excelmax, ivair ferrari
topo, excelmax, excel, ivair ferrari