6° Super desafio do ExcelMax® aos usuários do Excel | Excelmax Soluções e Controles

segunda-feira, agosto 01, 2011

6° Super desafio do ExcelMax® aos usuários do Excel

6° Super desafio do ExcelMax® aos usuários do Excel:

  • Uma planilha possui: Datas na coluna "A" e números de 1 à 999 nas colunas "B" à "F" em várias linhas que podem repetir. Preciso encontrar as datas para os números que se repetem e listar: números e datas (na mesma linha).
Este desafio foi sugerido por um amigo e seguidor do ExcelMax®: Douglas Z.

Nesta postagem veremos duas soluções:
  1. Utilizando Tabela dinâmica
  2. Utilizando Macro


1ª - Solução - Sugestão do amigo Otávio


Para a solução utilizando uma 'Tabela Dinâmica':

  1. Digitar: Data na célula 'H1' e Nºs na célula 'I1';
  2. Copiar os dados da coluna 'A', que contém as datas, para a coluna 'H';
  3. Copiar os valores da coluna 'B' para a coluna 'I';
  4. Copiar os dados da coluna 'A', que contém as datas, abaixo da última data na coluna 'H';
  5. Copiar os valores da coluna 'C' abaixo da última data na coluna 'I';
  6. Repetir os passos '4' e '5' para as colunas: 'A' e 'D', 'A' e 'E', 'A' e 'F';
  7. Selecionar a célula 'H1' e clicar em Inserir / Tabela Dinâmica;
  8. Inserir a Tabela Dinâmica na célula 'K1';
  9. Na área 'Rótulos de Linha' inserir os campos: 'Nºs' e 'Data'.
Com estes passos, concluímos o processo. Veja figura abaixo:












2ª - Solução - Sugestão ExcelMax®

Para a solução utilizando uma 'Macro':
  1. Digitar: N° na célula 'H1', Qtdade na célula 'I1' e Datas na célula 'J1';
  2. Digitar os n°s de 1 à 999 a partir da célula 'H2' (para baixo);
  3. Digitar a função: '=CONT.SE($B$2:$F$301;H2)' na célula 'I2' e copiá-la para baixo até a última linha que contenha valores na coluna 'H'.
  4. Criar uma Macro, conforme figura a seguir:

Agora é só executar a macro e o processo estará concluído.

Link para download: Planilha - 6o Desafio ExcelMax.

Até a próxima....



Sobre o autor: Ivair Ferrari é Certificado: Microsoft Office Excel Specialist; Consultoria e Desenvolvimento de Soluções e Softwares em Excel/VBA, Bancos de dados Access, Firebird, Oracle, Interação com SAP/R3 e Treinamentos In-Company. YouTube | Facebook | LinkedIn | Twitter | Google Plus

0 comentários :

Postar um comentário

Seja um participante desta comunidade !
Deixe aqui seu comentário e/ou sugestão.
Obrigado !

Ivair Claudio Ferrari

atualizar, excel, excelmax, ivair ferrari
topo, excelmax, excel, ivair ferrari