5° Super desafio do ExcelMax® aos usuários do Excel | Excelmax Soluções e Controles

sexta-feira, julho 01, 2011

5° Super desafio do ExcelMax® aos usuários do Excel


5° Super desafio do ExcelMax® aos usuários do Excel:
  • Preciso calcular: Anos, Meses e Dias entre duas datas

Por alguns fatores, podemos encontrar certa dificuldade para obter o resultado do cálculo mencionado acima:
  • Ano Bissexto
  • Meses com quantidades diferentes de dias

Nesta postagem veremos duas das melhores respostas enviadas ao ExcelMax®.


1ª - Resposta - Enviada pelo amigo Otávio:

Inserimos:
  • Data Início na célula A2
  • Data Fim na célula B2

DIAS à Com a utilização de algumas funções: SE, MÊS, DIA, ANO:
  • =SE(MÊS(B2)>MÊS(A2);ANO(B2)-ANO(A2);SE(MÊS(B2)<MÊS(A2);ANO(B2)-ANO(A2)-1;SE(DIA(B2)>=DIA(A2);ANO(B2)-ANO(A2);ANO(B2)-ANO(A2)-1)))

MESES à Com a utilização de algumas funções: SE, MÊS, DIA:
  • =SE(DIA(B2)>=DIA(A2);SE(MÊS(B2)>=MÊS(A2);MÊS(B2)-MÊS(A2);MÊS(B2)-MÊS(A2)+12);SE(MÊS(B2)>MÊS(A2);MÊS(B2)-MÊS(A2)-1;SE(MÊS(B2)<MÊS(A2);MÊS(B2)-MÊS(A2)+11;11)))

ANOS à Com a utilização de algumas funções: SE, DIA, FIMMÊS:
  • =SE(DIA(B2)>=DIA(A2);DIA(B2)-DIA(A2);FIMMÊS(A2;0)-DIA(A2)+DIA(B2))

Obs. As fórmulas podem ser agrupadas com a utilização da função CONCATENAR ou o operador "&".



2ª - Resposta Enviada pelo amigo Wellington:






Inserimos:
  • Data Início na célula A2
  • Data Fim na célula B2
Com a utilização da função DATADIF podemos calcular o número de dia(s), mês(es) ou ano(s) entre duas datas.

Sintaxe: DATADIF ( data_inicial , data_final , unidade )

Unidade: O tipo de informação que você deseja retornar.
  • "Y" à Retorna o número de anos completos no período.
  • "M à Retorna o número de meses completos no período.
  • "D" à Retorna o número de dias no período.
  • "MD" à Retorna a diferença entre os dias na data_inicial e data_final. Os meses e anos das datas são ignorados.
  • "YM" à Retorna a diferença entre os meses na data_inicial e data_final. Os dias e anos das datas são ignorados.
  • "YD" à Retorna a diferença entre os dias da data_inicial e data_final. Os anos das datas são ignorados.


DIAS à =DATADIF(A2;B2;"md")

MESES à =DATADIF(A2;B2;"ym")

ANOS à =DATADIF(A2;B2;"y")


Obs. As fórmulas podem ser agrupadas com a utilização da função CONCATENAR ou o operador "&". Exemplo:
  • =DATADIF(A2;B2;"y") & " Ano(s) " & DATADIF(A2;B2;"ym") & " mês(es) " & DATADIF(A2;B2;"md") & " dia(s)"
  • Exemplo: 40 Ano(s) 7 mês(es) 28 dia(s)

Obrigado a todos que participaram !!!



Sobre o autor: Ivair Ferrari é Certificado: Microsoft Office Excel Specialist; Consultoria e Desenvolvimento de Soluções e Softwares em Excel/VBA, Bancos de dados Access, Firebird, Oracle, Interação com SAP/R3 e Treinamentos In-Company. YouTube | Facebook | LinkedIn | Twitter | Google Plus

Um comentário :

  1. Muito boa a proposta do amigo Otávio. Também gosto muito da utilização de diversos SEs. hehe

    ResponderExcluir

Seja um participante desta comunidade !
Deixe aqui seu comentário e/ou sugestão.
Obrigado !

Ivair Claudio Ferrari

atualizar, excel, excelmax, ivair ferrari
topo, excelmax, excel, ivair ferrari