Crie Funções para facilitar Cálculos | Excelmax Soluções e Controles

quinta-feira, abril 21, 2011

Crie Funções para facilitar Cálculos


Crie suas Funções no Excel
Para efetuarmos cálculos no Excel, precisamos criar fórmulas utilizando uma ou mais funções. Muitas vezes isso é bastante trabalhoso dependendo do tipo de cálculo e que resultado precisamos extrair de determinada base de dados.

Para facilitar, podemos criar funções no Excel que simplificam o trabalho. Esta postagem demonstra como podemos fazer isso.


Vamos supor que precisamos calcular a média de uma determinada quantidade de números em uma base de dados.

Podemos fazer isso da seguinte maneira (utilizando as funções do Excel):
  • A média aritmética dos dois (2) maiores números;
  • A média aritmética dos quatro (4) menores números.

A média aritmética dos dois (2) maiores números

    =SOMASE(B2:B21;">="&MAIOR(B2:B21;2);B2:B21)/CONT.SE(B2:B21;">="&MAIOR(B2:B21;2))

A média aritmética dos quatro (4) menores números

  =SOMASE(B2:B21;"<="&MENOR(B2:B21;4);B2:B21)/CONT.SE(B2:B21;"<="&MENOR(B2:B21;4))


Podemos notar uma certa complexidade nas duas fórmulas.
Para simplificar isto, podemos criar funções, que retornam o mesmo resultado.

Função MédiaMaiores

    Function MédiaMaiores(Intervalo, Num)
        soma = 0
        For i = 1 To Num
            soma = soma + Application.Large(Intervalo, i)
        Next i
        MédiaMaiores = soma / Num
    End Function

Função MédiaMenores

    Function MédiaMenores(Intervalo, Num)
        soma = 0
        For i = 1 To Num
            soma = soma + Application.Small(Intervalo, i)
        Next i
        MédiaMenores = soma / Num
    End Function

A figura abaixo demonstra o resultado para o cálculo com a utilização das novas funções que foram criadas com o Visual Basic.



  



















Se gostou desta postagem, divulgue a seus amigos.

Se desejar mais algum exclarecimento, favor postar comentário.

Se desejar sugerir um assunto específico para uma postagem, fique a vontade sugerindo através dos comentários ou enviando email: ivairferrari@gmail.com.

Download: Função Média Maiores e Menores




   


Sobre o autor: Ivair Ferrari é Certificado: Microsoft Office Excel Specialist; Consultoria e Desenvolvimento de Soluções e Softwares em Excel/VBA, Bancos de dados Access, Firebird, Oracle, Interação com SAP/R3 e Treinamentos In-Company. YouTube | Facebook | LinkedIn | Twitter | Google Plus

0 comentários :

Postar um comentário

Seja um participante desta comunidade !
Deixe aqui seu comentário e/ou sugestão.
Obrigado !

Ivair Claudio Ferrari

atualizar, excel, excelmax, ivair ferrari
topo, excelmax, excel, ivair ferrari