Impedir ou destacar a digitação de códigos repetidos | Excelmax Soluções e Controles

segunda-feira, janeiro 24, 2011

Impedir ou destacar a digitação de códigos repetidos

    Algo que me deixa feliz ao passar um pouco do conhecimento que tenho, é quando percebo que, quem está aprendendo, realmente se empenha em aprender e passa a utilizar tal conhecimento para agilizar suas tarefas.
    O exemplo apresentado a seguir, tem a participação de meu amigo: Diógenes Herbert Bagnara.

    Impedir ou destacar a digitação de códigos repetidos:

    Muitas vezes podemos precisar digitar, em uma coluna, números para, por exemplo, um orçamento. Nesta coluna (coluna 'material'), não queremos que os códigos digitados se repitam (ocorram mais de uma vez). Para destacar quando isso acontecer, podemos utilizar a opção 'Formatação Condicional' e, se quisermos impedir que isto aconteça, podemos utilizar a ferramenta 'Validação de dados'.

    No exemplo a baixo, na coluna 'Material', apliquei uma 'Formatação Condicional' que destaca na cor 'preta', os números que se repetirem uma ou mais vezes. A fórmula utilizada (na formatação condicional) para que isto aconteça é a seguinte:
  • =SE(CONT.SE($A$6:$A$18;A6)>1;VERDADEIRO;FALSO)



 

    Neste segundo exemplo, na coluna 'Material', apliquei uma 'Validação de Dados' que bloqueia a entrada de números que se repetirem (veja a figura). A fórmula utilizada na 'Validação de Dados' para que isto aconteça é a seguinte:
  • =SE(CONT.SE($A$6:$A$18;A6)>1;FALSO;VERDADEIRO)

    Os dois exemplos apresentados são importantes e ainda, podem ser utilizados juntos para uma maior eficácia
. O link abaixo permite o download do arquivo de exemplo para um melhor entendimento e utilização.


    Em caso de dúvidas, favor contatar (ivairferrari@gmail.com) ou postar comentário nesta postagem.

Sobre o autor: Ivair Ferrari é Certificado: Microsoft Office Excel Specialist; Consultoria e Desenvolvimento de Soluções e Softwares em Excel/VBA, Bancos de dados Access, Firebird, Oracle, Interação com SAP/R3 e Treinamentos In-Company. YouTube | Facebook | LinkedIn | Twitter | Google Plus

Um comentário :

  1. Muito bom este recurso, bastante util quando se esta trabalhando com lancamentos de dados. Parabens pelo post.

    ResponderExcluir

Seja um participante desta comunidade !
Deixe aqui seu comentário e/ou sugestão.
Obrigado !

Ivair Claudio Ferrari

atualizar, excel, excelmax, ivair ferrari
topo, excelmax, excel, ivair ferrari